Degraded API and dashboard performance
Incident Report for Balena.io
Resolved
This incident has been resolved.
Posted Jul 13, 2018 - 20:05 UTC
Investigating
We are currently investigating this issue.
Posted Jul 13, 2018 - 17:57 UTC
This incident affected: API and Dashboard.