Intercom is experiencing downtime
Incident Report for Balena.io
Resolved
This incident has been resolved.
Posted Jan 19, 2017 - 18:35 UTC
Monitoring
Intercom is experiencing partial outage; if you have questions please use our forums to ask — we’ll be there to answer!
Posted Jan 19, 2017 - 14:41 UTC